Utiliser les fonctions de recherche avec Excel

Publié: 1 octobre 2012 dans Open Office Calc

Téléchargez ce tutoriel en PDF >EXCEL Utiliser les fonctions de recherche

L’exercice consiste à rapatrier les données d’une feuilles de calcul vers une autre feuille de calcul qui est une facture.

Une fois que les formules de recherches seront insérées dans la facture la seule saisie de la référence affichera le nom et le prix du produit.

Pour cela dans Excel saisir les données suivantes sur une feuille que l’on va nommer données.

A B C
1 Réf Nom Prix
2 Im1 Multipass c400 297€
3

Im2

Multipass c600f

421€
4

Im3

LBP-1210 358€
5

Im4

LBP-1120 262€
6

Im5

BJC-85 257€
7

Im6

S900photo 401€
8

Im7

S820D 378€
9

Im8

S200x 69€
10

Im9

I 550 170€

A noter que la colonne Réf doit être triée par ordre croissant

Enregistrer le classeur sous le nom facture.

Dans la feuille 2 (renommez-la facture) construisez le tableau de résultat suivant :

A

B

C

D

E

1 Facture
2
3 Réf Nom Prix Qté Total HT
4
5
6
7
8
9
10          

Construire une formule de recherche :

  • saisir Im3 dans la cellule A4 c’est la valeur recherchée

Pour rapatrier le nom du produit :

  • Cliquer sur la cellule B4 c’est ici que doit apparaître le nom du produit qui correspond à la référence demandé.
  • Taper la formule =RECHERCHEVla lettre V indique que l’on fait une recherche Verticale car les données sont en colonne . Pour une recherche Horizontale remplacer par H)
  • Cliquez ensuite sur A4 contenant la référence du produit et point virgule pour la séparation.
  • Cliquez ensuite sur la feuille données et sélectionnez toute les données de la feuille cellule A2 à C10 appuyez sur la touche F4
  • Tapez dans la barre de formule ;2) car la valeur à rapatrier se trouve sur la deuxième colonne

On obtient la formule suivante dans la cellule B4 : =RECHERCHEV(A4;données!$A$2:$C$10;2)

Faites entrer, tester et tirer la formule dans la colonne B et recommencez l’opération sur la cellule C4 pour faire apparaître le prix.

Source : http://coursinfo.free.fr


(adsbygoogle = window.adsbygoogle || []).push({});

Publicités

Les commentaires sont fermés.