OpenOffice Calc Fonction arrondi

Publié: 16 avril 2012 dans Open Office Calc

La fonction ARRONDI d’Excel ou Calc  permet de modifier un nombre en lui assignant un nombre de décimales précis.

Par exemple, si la cellule A2 contient le nombre 1234,5678, la formule =ARRONDI(A2;2) donne le résultat 1234,57 (remarquez que la deuxième décimale a été arrondie à sa valeur supérieure, la suivante étant supérieure ou égale à 5).

Tout cela est très classique. Le nombre de décimales peut être négatif, dans ce cas, l’arrondi se fait sur des puissances de dix.

Ainsi, avec notre même exemple, =ARRONDI(A2;-1) renvoie la valeur 1230 (soit 1234,5678 arrondi à la dizaine la plus proche). Avec un argument de -2, l’arrondi se ferait à la centaine la plus proche (soit 1200) et ainsi de suite.

Mais la fonction ARRONDI présente une lacune : elle ne vous permet pas de demander un arrondi à un nombre imposé de « chiffres significatifs », une notion très utilisée en sciences.

Par exemple, en ne gardant que deux chiffres significatifs, 345000 serait arrondi à 340000 et 0,234567 deviendrait 0,23 avec, vous le voyez, un nombre variable de décimales.

Il s’agit ici de définir une précision globale et c’est ainsi que fonctionnent la plupart des appareils de mesure. Pour obtenir ce résultat, il suffit d’utiliser, comme second argument de la fonction ARRONDI, le logarithme décimal du nombre à arrondir car ce dernier dépend du nombre de chiffres de sa partie entière.

Ainsi, la formule =ARRONDI(A2;1-LOG(E2)) conserve les deux premiers chiffres de A2. Pour conserver trois chiffres significatifs, remplacez 1-… par 2-

Ce petit tableau pour résumer les différentes possibilités


(adsbygoogle = window.adsbygoogle || []).push({});

Les commentaires sont fermés.